Simulating NSSA and restricting LSA Topology

Simulating NSSA and restricting LSA Topology

Configuring Router R1

R1#en
R1#conf t
R1(config)#interface s1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#ip ospf 1 area 1
R1(config-if)#interface loopback 0
R1(config-if)#ip address 10.1.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#ip ospf 1 area 1

R1(config-if)#interface loopback 1
R1(config-if)#ip address 10.1.3.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#ip ospf 1 area 1

R1(config-if)#interface

read more

Simulating OSPF with STUB AREA, NSSA, Restricting LSA’s

Simulating OSPF with STUB AREA, NSSA, Restricting LSA’s

CODE
Configuring Router R1

R1#en R1#conf t R1(config)#interface loopback 1 R1(config-if)#ip address 10.1.2.1 255.255.255.0 R1(config-if)#no shutdown R1(config-if)#ip ospf 1 area 1 R1(config-if)#interface loopback 2 R1(config-if)#ip address 10.1.3.1 255.255.255.0 R1(config-if)#no shutdown R1(config-if)#ip ospf 1 area 1 R1(config-if)#interface loopback 3 R1(config-if)#ip address

read more

Multicast Routing

Multicast Routing In multicasting there is at least one sender and several receivers (group of receivers called (multicast group) In multicast routing, the router may forward the received packet through several of its interfaces.

Configurations of all the routers
Router R1

R1#en R1#conf t R1(config)#int f1/0 R1(config-if)#ip add 192.168.12.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1(config-router)#router ospf 1 R1(config-router)#network 0.0.0.0 255.255.255.255 area 0 R1(config-router)#exit R1(config)#ip multicast-routing R1(config)#int f1/0 R1(config-if)#ip pim sparse-dense-mode R1(config-if)#exit R1(config)#int f1/1 R1(config-if)#ip

read more

Simulating EBGP

Simulating EBGP

Router R1

R1(config-if)#int f1/0
R1(config-if)#ip add 192.168.12.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config-if)#int  loopback0
R1(config-if)#ip  add 1.1.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#

Adding bgp adjacencies between AS1 and AS2 and advertising the loopback interface

R1(config)#router bgp 1 R1(config-router)#neighbor 192.168.12.2 remote-as 2 R1(config-router)#exit R1(config)#router bgp 1 R1(config-router)#network 1.1.1.0

read more

Simulating Simple BGP

Simulating Simple BGP:

BGP is Primarily used to support the complexity of the public Internet, Cisco has added several clever and useful features to its BGP implementation (BGP 4). Some of the primary attributes of BGP is the use of pieces of information about a known route, where it came from, and how to reach it, A BGP router will also generate an error message if it receives a route that is missing these are mandatory attributes.

Configuring IP addresses on all the interfaces
Router R1

Router(config)#int f1/0
Router(config-if)#ip add 192.168.0.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#

Router R2

R2(config)#int f1/0
R2(config-if)#ip add 192.168.0.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int f1/1
R2(config-if)#ip add 10.0.0.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#

Router R3

Router#conf t Enter

read more